Проблемы при StreamTimeOut < 100 мс


Проблемы при StreamTimeOut < 100 мс
Atom Reply
9/30/2011


При уменьшении StreamTimeOut до 50 через некоторое время прекращают поступать данные.
А если делать этот параметр равным например 100 то данные поступают очень медленно...

Tags:


Thanks:




15 Answers
Alexander

Avatar
Date: 9/30/2011
Reply


frontman Go to
При уменьшении StreamTimeOut до 50 через некоторое время прекращают поступать данные.
А если делать этот параметр равным например 100 то данные поступают очень медленно...


Что значит очень медленно? StreamTimeOut за поступление данных не отвечает. Не может быть при 100мс медленно, при 50 - быстро. Этот параметр за другое отвечает, он в ProcessMessage передаётся.
Прекращают по какой причине - что пишет ProcessDataError?

Я несколько дней тестил плазу вдоль и поперёк, с таким не сталкивался.
Thanks:

frontman

Avatar
Date: 9/30/2011
Reply


ProcessDataError ничего не пишет.
Задержка почему то и правда зависит от StreamTimeOut.
На практике видно.
Правда я исп версию 4.0 без последних фиксингов...
Topic starter
Thanks:

Alexander

Avatar
Date: 9/30/2011
Reply


frontman Go to
ProcessDataError ничего не пишет.
Задержка почему то и правда зависит от StreamTimeOut.
На практике видно.
Правда я исп версию 4.0 без последних фиксингов...


Используйте с последними фиксами.
Пологгируйте - на каком этапе возникает задержка? Может поток висит который ProcessMessage выполняет?
Thanks:

frontman

Avatar
Date: 9/30/2011
Reply


Возможно... Спасибо за подсказку. Буду смотреть...
Topic starter
Thanks:

frontman

Avatar
Date: 9/30/2011
Reply


Если что то накопаю обязательно отпишусь))
Topic starter
Thanks:

FiNick

Avatar
Date: 9/30/2011
Reply


frontman Go to
ProcessDataError ничего не пишет.
Задержка почему то и правда зависит от StreamTimeOut.
На практике видно.
Правда я исп версию 4.0 без последних фиксингов...


Релиз 4.0 какраз была выпущена за день до того, как все проблемы с задержками плазы решили. Так что берите последнюю версию
Thanks: frontman

frontman

Avatar
Date: 9/30/2011
Reply


С новыми библиотеками 4.0.1 заявки (история) стали приходить значительно медленнее, а последние вообще не приходят. В коде абсолютно никаких изменений! Как это может быть?
Topic starter
Thanks:

FiNick

Avatar
Date: 9/30/2011
Reply


frontman Go to
С новыми библиотеками 4.0.1 заявки (история) стали приходить значительно медленнее, а последние вообще не приходят. В коде абсолютно никаких изменений! Как это может быть?

Вы какой пример запускаете, SimpleGUI? Там есть такая фишка Save/LoadRevision, у меня работет криво как-то, последние данные не приходят, потому отключил.
Thanks:

frontman

Avatar
Date: 9/30/2011
Reply


Я пример не запускаю. Я на своем коде тестил. После смены библиотеке тормоза поперли.
Но Save/LoadRevision в своем коде я то же исп...
Topic starter
Thanks:

frontman

Avatar
Date: 9/30/2011
Reply


Короч нет. Убрал. Все то же...
Надо попробовать SimpleGUI запустить... Посмотреть как там...
Topic starter
Thanks:

frontman

Avatar
Date: 9/30/2011
Reply


Запустил пример SimpleGUI
1) После подключения к роутеру приложение минуты 3 висит и вообще не реагирует ни на что.
2) Открываю заявки - пусто.
Topic starter
Thanks:

frontman

Avatar
Date: 9/30/2011
Reply


Тот же SimpleGUI версии 4.0 работает норм...
Topic starter
Thanks:

frontman

Avatar
Date: 9/30/2011
Reply


frontman Go to

2) Открываю заявки - пусто.

Вот еще через минуту после открытия окна что то появилось. Но заявки старые и новые неизвестно еще через сколько придут...
Topic starter
Thanks:

frontman

Avatar
Date: 9/30/2011
Reply


Все. Я устал ждать короч) Так и не прокачал историю даже...
Topic starter
Thanks:

frontman

Avatar
Date: 10/3/2011
Reply


Проблема решена. В Форумы
Stock# » Коннекторы » Plaza2 » Публичный бета тестинг
описал все
Topic starter
Thanks:


Attach files by dragging & dropping, , or pasting from the clipboard.

loading
clippy