Проблемы с 2.6 и Visual Studio 2008


Проблемы с 2.6 и Visual Studio 2008
Atom Reply
12/6/2010


Перешел на новую версию с 2.3, из под студии если запускать то все нормально никаких проблем, а вот если студию закрыть и запустить программу из папки DEBUG, почему-то робот не соединяется с Квик, Trader.Connected просто не вызывается. В квике вижу, что добавляются счета и все, на этом стопорится, никаких исключений ничего. Первый раз с такой проблемой столкнулся, до этого еще почему-то и библиотеки из папки DEBUG удалялись не занесенные в ссылки проекта(например NDde.dll). Добавил все библиотеки в ссылки, чувствую, что проблема где-то в настройках проекта, но вот где понять не могу. С 2.3 проблем никаких не было. Переходил на новую версию так, удалял все ссылки на библиотеки с проекта, удадлял все библиотеки, копировал новые, добавлял ссылки, больше ничего не менял.

Tags:


Thanks:




4 Answers
ustas

Avatar
Date: 12/6/2010
Reply


Попробую угадать. Вы работаете на Виста или Win7?
Visual Studio запускаете с правами администратора и оттуда всё работает. Так?
Quik запускаете от администратора? Это не обязательно.
Thanks:

Garry

Avatar
Date: 12/6/2010
Reply


Да Windows 7. Студия с правами стандартными ничего не трогал. Попробовал сейчас запустить робота от имени администратора, с квиком соединился теперь ДДЕ не стартует, точнее старт происходит но ДДЕ сервер не находит. "Не удалось установить DDE соединение с сервером wrapper". Какие разрешения ему дать или может в локальной политике что-то подправить? Quik запускаю обычно.
Topic starter
Thanks:

ustas

Avatar
Date: 12/6/2010
Reply


а Verifier что говорит?
для разнообразия попробуйте запустить Quik тоже от администратора, что то поменялось?
Thanks:

Garry

Avatar
Date: 12/6/2010
Reply


Почему-то права на папку квика стояли на изменение только у администраторов и системы. Дал всем все права, теперь все вроде работает, если запускать робота по обычному и квик по обычному. Если запускать робота от администратора, по прежнему квик не может найти ДДЕ. Когда запускаешь квик от администратра, то вообще чудеса, не видит файлы ключей и не подгружает файл настроек, похоже на них тоже какие-то особые права стоят, ну да заработало и ладно. Спасибо за советы.
Topic starter
Thanks:


Attach files by dragging & dropping, , or pasting from the clipboard.

loading
clippy