ошибка при загрузки скрипта StockSharp.Quik.lua в терминал Quick


ошибка при загрузки скрипта StockSharp.Quik.lua в терминал Quick
Atom Reply
9/10/2019


Всем добрый день,

Пытаюсь подключиться гидрой к терминалу Quick версии 8.0. на windows 10 64-bit. Когда загружаю скрипт StockSharp.Quik.lua в в терминал Quick у меня выходит сообщение:

error loading module 'StockSharp' from file 'C:\StockSharp_4.4.16_ru\References\StockSharp.QuikLua.dll':
%1 не является приложением Win32.

Далее если хочу подключиться к к терминалу Quick версии 7.0. на windows 10 32-bit, тогда при загрузки скрипта StockSharp.Quik.lua у меня выходит сообщение об ошибке:

error loading module 'StockSharp' from file 'C:\Users\roman\Desktop\Hydra\StockSharp.QuikLua.dll':
Не найден указанный модуль.

Сам файл StockSharp.QuikLua.dll лежит у меня в той папке откуда, я запускаю гидру.

Установлены Visual C++ 2015-2019

Может кто сталкивался с такой проблемой подскажите плиз как решили?




Thanks:




11 Answers
JohnRisker

Avatar
Training Donator
Date: 11/18/2019
Reply


Столкнулся с такой же ошибкой. Кто-то может подсказать в чем дело?
Thanks:

JohnRisker

Avatar
Training Donator
Date: 11/18/2019
Reply


Если кому интересно: скачал "ночную сборку" вместо последней версии с GitHub и все заработало
Thanks:

zenp

Avatar
Date: 4/20/2020
Reply


Что за ночная сборка?
Thanks:

DaTo

Avatar
Training
Date: 4/23/2020
Reply


и где их качать?

у меня 4.4.16 с 7м квиком срослось. квик принял скрипт.
Thanks:

ring1010

Avatar
Date: 4/24/2020
Reply


Такое впечатление, что разработчики намеренно этот файл StockSharp.QuikLua.dll не положили в загрузку. Чтобы пользователи помучались и бросили. Злость берет. Плохие словами хочется употребить!! Его еще надо скачивать загрузив всю сборку из Nuget. А он все равно не нерабочий Почему при установке Терминала или Дизайнера это не сделать!
Thanks: Алексей

Алексей

Avatar
Donator
Date: 4/24/2020
Reply


ring1010 Перейти
Такое впечатление, что разработчики намеренно этот файл StockSharp.QuikLua.dll не положили в загрузку. Чтобы пользователи помучались и бросили. Злость берет. Плохие словами хочется употребить!! Его еще надо скачивать загрузив всю сборку из Nuget. А он все равно не нерабочий Почему при установке Терминала или Дизайнера это не сделать!


Сам убил на это не один день, похоже надо пробовать с помощью утилиты NugetInstaller https://stocksharp.ru/ne...po-nuget/#nugetinstaller
Не забудьте создать Documents\UserName\StockSharp\
Thanks:

ring1010

Avatar
Date: 4/24/2020
Reply


Этот #nugetinstaller по платной подписке, не дает скачивать. Аксес денаед!! В общем иллюзия бесплатности. Потрать кучу времени и получи ничего. Зачем было объявлять бесплатно.Лучше бы честно выставили бы оплату. И люди само определились бы. ((((
Thanks:

ring1010

Avatar
Date: 4/24/2020
Reply


Пришлось 7 версию Квика и 4.4.16 запустился скрипт
Thanks:

DaTo

Avatar
Training
Date: 4/25/2020
Reply


квик 8 не воспринял скрипт луа из stocksharp.quicklua версии 5.0.6.
скажите, когда будет исправление?
Thanks:

Kingrai

Avatar
Date: 5/14/2020
Reply


1. В VS устанавливаем с помощью NuGet пакеты StockSharp.Quik и StockSharp.QuikLua
2. путь проекта\packages\StockSharp.QuikLua.5.0.11\contentFiles\any\any - здесь находится скрипт StockSharp.QuikLua
3. В эту папку необходимо забросить все dll StockSharp подключенные к проекту. Я просто скомпилировал проект и из папки bin/debug скопировал все dll.
Thanks:

Marat

Avatar
Date: 5/14/2020
Reply


Для удобства установки вы можете воспользоваться утилитой NugetInstaller, расположенной на нашем сайте.
Приятного пользования.
Thanks:


Attach files by dragging & dropping, , or pasting from the clipboard.

loading
clippy