Requesting help with Interop.SterlingLib
Atom Reply
3/7/2019


I tried the Designer application and also created a new project following the instructions here https://www.youtube.com/watch?v=O8ucIQA829w but whenever I try to verify the sterling connection i get the error "Could not load file or assembly 'Interop.SterlingLib' ...

In both cases Sterling is running and the Interop.SterlingLib.dll looks to be in the correct place.

Any thoughts?
Error in Designer.PNG 28.5KB (4) Nuget.PNG 31.3KB (5)



Thanks:




5 Answers
Support

Avatar
Date: 3/7/2019
Reply


Thank you for your message. The first message mean the versions are incompatible. What the version of Sterling do you use? When happened errors with another message (dll not found)?
Thanks:

James

Avatar
Date: 3/7/2019
Reply


Sterling's version is 11.6

I tried the pro version and the elite version.

The dll not found happened from the project I created following https://www.youtube.com/watch?v=O8ucIQA829w , the dll is in the references of the project.

Thank you for your time!
Topic starter
Thanks:

Support

Avatar
Date: 3/9/2019
Reply


We got the response from the dev team and they will adapt our connector to the newest version. Please clarify what the broker do you use.

For the second issue please add directly Interop assembly to your project as a reference.
Thanks:

James

Avatar
Date: 3/10/2019
Reply


For the first issue ( Designer application ) it is now working.

The second issue is not resolved, where I create my own project and download the nuget package StockSharp. The Interop.SterlingLib from the nuget package is not compatible with Sterling Trader Pro 11.6 or 11.7

Thank you!
Topic starter
Thanks:

Support

Avatar
Date: 3/15/2019
Reply


Thank you for your feedback. Please download night build S#.API where we updated Sterling Connector to the newest version.
Thanks:


Attach files by dragging & dropping, , or pasting from the clipboard.

loading
clippy